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Introduction 
 

FxCraft Trade Manager (hereinafter referred to as FTM) is a tool for placing orders on the Forex market. 
Therefore, before using it read and accept the following conditions: 

1) Currency trading in the Forex market on margin carries a high level of risk and may not be 

suitable for all investors. The high degree of leverage may work against you as well as for you. 

Before making a decision on investing in the Forex market by FxCraft Trade Manager, you should 

thoroughly consider your investment objectives, level of experience, and your risk appetite. The 

possibility exists that you can sustain a loss of some or all of your equity and therefore you 

should not invest money that you cannot afford to loose. You should be aware of all the risks 

associated with foreign exchange trading, and seek advice from an independent financial 

advisor if you have any doubts. 

2) FxCraft shall not be liable for any loss or damage of any kind, including any direct, indirect or 

consequential damages incurred by the Investor while using FxCraft Trade Manager whether its 

action was correct or not.  Therefore, we recommend you to thoroughly test and familiarize 

yourself with FxCraft Trade Manager in a DEMO account before you start using it in your real 

account. 

3) If you notice any abnormality in FxCraft Trade Manager immediately stop the program and 

report the problem to the FxCraft company by sending an email on office@fxcraft.biz address. 

Without the acceptance of the above conditions do not install or use FxCraft Trade Manager. 
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Short description of the product 
 

FxCraft Trade Manager (FTM) is a convenient tool for manual trading on the most popular Forex 

platform – MetaTrader 4.  

It allows for quick and intuitive opening, closing and managing orders on the MetaTrader 4 platform. 

It facilitates and accelerates execution of many standard actions, which often take our precious time and 

increase chances of making mistakes. 

It is perfectly suited for dynamic scalping and traditional day-trading. 

FTM enables among other things to send market or pending orders with Stop Loss and Take Profit of 

a certain size (order lots defined by the user or calculated on the basis of specified risk) by one click 

or keyboard shortcut. We can also specify the date and the time when the order (or orders) will be 

opened. It is possible to (partially) close orders as well as selected types of orders. 

By FTM we can manage open orders in many ways by defining e.g. Trailing Stop, Break Even, Global Take 

Profit, Global Stop Loss. It is also possible to define levels of partial closing of open orders. We have the 

ability to quickly modify the levels of Stop Loss, Take Profit and Open Price of a pending order. There is 

also an option to reverse the position by one click.  
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Installation 
 

The downloaded zip file should be unpacked. Then, copy the FxCraftTradeManager.dll file into the 

\MT4_Directory\MQL4\Libraries directory and place the FxCraftTradeManager.ex4 file in the 

\MT4_Directory \MQL4\Experts directory. 

The easiest way to open MT4_Directory is to click File -> Open Data Folder on the MetaTrader 4 

platform. 

 

After placing the FTM files in appropriate directories restart the MetaTrader 4 platform. Now the FTM 

will be ready to run in the Navigator window on the MetaTrader 4 platform. 
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To start the FTM on the selected currency pair drag and drop FxCraft Trade Manager onto the desired 

chart. 

During the launch of the FTM, a window with parameters will appear. Make sure that the options ”Allow 

DLL imports” and ”Allow live trading’’ are selected. 

 

You should also check if the “AutoTrading’’ button on the MT4 platform is enabled.  

 

Once the program is started successfully a smiled face in the upper right corner signals that the FTM is 

ready to run. 
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Main Window 
 

 

 

“Default” tab 
 

Buttons for opening positions. Clicking on a button opens a 

position with parameters defined below in the visible tab. This 

position is tagged with a magic number defined in the “magic’’ 

parameter during the start of the program. 

Above the buttons the current Spread value is displayed. 

Below on the left side profit/loss in the currency of the account of 

currently opened positions with given magic number is displayed. Commissions and swaps are taken 

into account when counting profits/losses. In brackets a value measured in points, which denotes the 

distance from the current price to the Break Even level (the price at which the total profit of all market 

orders with given magic number is equal to 0), is shown. 

Below, on the right side, the total lot size (negative values means the dominance of short positions) and 

the number of open positions with given magic number are displayed. 

 

 

The panel which is responsible for opening pending orders. If 

“Pending” is selected, then after clicking the Sell or Buy button 
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pending order will be opened at the selected level. You can set this level as the point measured distance 

from the current price or written price level. An appropriate option is chosen from the list at the end of 

the panel. If the option of the distance from the price is selected and the entered value is greater than 

zero, the STOP order will be opened. If the value is negative, the LIMIT order will be opened. 

 

 

The panel which is responsible for the size of a pending position. If 

“Risk” is not selected the size of an opening position is taken from 

the „Lot” field. Otherwise, the size of the position is counted in such a way that in case of Stop Loss the 

position will not have loss greater than the given nearby “Risk” field percent of the current account’s 

capital (the size of Equity). Calculation of the size of the position based on a percentage of risk is 

possible if the value of Stop Loss is set. 

 

  

The panel which is responsible for setting the Stop Loss and Take 

Profit values of an order. It is possible to set these parameters as a 

distance in points from opening price or at a specified price level. 

An appropriate option is chosen from the list at the end of the panel.  

 

 

The panel which is responsible for setting the maximum Spread at which a 

Market order can be opened. 

 

 

The panel which is responsible for setting the maximum price deviation 

during the opening of an order. 

  

Individual panels can be selected in the mouse right-

click menu on the “Default” Tab.  
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”Both sides” tab 
 

 

 

 

Choosing the „Both sides” tab allows you to set various parameters separately for Sell (left column) and 

Buy (right column) orders. In addition there is a button “Open Both” which allows you to simultaneously 

open Sell and Buy orders. Orders are opened in accordance with the parameters defined under the 

buttons.  
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Closing panel  
 

The panel is responsible for closing various types of positions. 

It is possible to close all Sell, Buy, Pending Sell, Pending buy 

and all orders. You can hide/show the buttons in the “View” 

menu or by clicking the right mouse button in the closing 

panel. 

 

 

 

 

 

 

 

 

 

 

 

 

If you select the “Always on top” option, the FTM window will be 

always displayed on the screen.  

The time of the last tick is displayed on the right side.  
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Order Table 
 

The order table can be opened by clicking Tools->Order Table.  

 

 

The table displays all orders opened by the FTM program or orders which have the same magic number 

that has been entered in the “magic” parameter during the start of the program. 

The table contains information about the ticket number, type and size of the order. In addition it is 

equipped with:  

 

 

Button for reversing position. When you click it, the selected order is closed and the reverse 

order is opened. The Stop Loss and Take Profit values of a new order are in the same 

distance from the opening price of the order as it was in the original order.  

 

In this part of the table, Opening Price (for pending 
orders), Stop Loss and Take Profit values of an order can 
be modified. To enter the edit mode, click the 
corresponding “Edit” button, which will change to the 
“Confirm” button. Afterwards, enter new values of 
parameters of the order. 
To confirm new values of parameters, click the “Confirm” 

button. This will set new values to the selected order. 
 

 These fields are used to modify a Stop Loss value of a selected order in a simple 
way. 
In the “SL Gain” field, we set the distance in points between new Stop Loss and 
the opening price of order. It is possible to enter negative values. Click the “Set” 

button to set Stop Loss to a defined level. 
   

 

 These fields are used for partial or complete closing of a selected 
order. Click the button in the “PC” column to close the percentage of 
the position, defined in the “% to PC” column. Click the button in the 

“Close” column to close the whole order. 
 

In addition, the current profit/loss in points of a given position is displayed in the “PC” column. The 
current profit/loss in an account currency of a given position is shown in the “Close” column. 
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In the mouse right-click 
menu one can select which 
columns are visible in the 
table of orders. 
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Options 
 

The options window can be opened by clicking Tools->Trade Options. 

To approve the changes to the settings, close the window by clicking the “Ok” button. Otherwise, click 
the “Cancel” button. Save changes (see section “Save settings”) to maintain them even after closing the 
program. 
 

SL/TP 

 

The Trailing Stop option is active (for all 
orders) provided that the “Trailing Stop” field 
is checked. 
 
The “Trailing Start” parameter enables to 

determine how many profit points are 

required to start modifying Stop Loss of an 

order. 

The “Trailing Distance” parameter enables to 
determine the distance in points from the 
current price and new Stop Loss. 
 

The “Trailing Step” parameter enables to 

determine the minimum distance in points 

from the current and new Stop Loss. 

 

The Break Even option is active (for all orders) 
provided that the “Break Even” field is 
checked. 
The “Break Even Start” parameter enables to 
determine how many profit points are 
required to move Stop Loss of an order. 

 

The “Break Even Gain” parameter enables to determine the distance in points from the opening price 
and new Stop Loss. This value can be negative. 
 

The Global Stop Loss option is used to close all open orders if the total gain/loss in an account currency 
is lower than an entered value. Negative values are used to define a loss. 
 
The Global Take Profit option is used to close all open orders if the total gain/loss in an account 
currency is greater than an entered value. Positive values are used to define a gain. 
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Partial Close 
 

The “Partial Close” tab enables to define any 
number of levels at which positions partially 
close. 
 

Whether or not a given level is active is 
determined in the “Use” column.  
 

In the “Points” column, we set the distance 
from the opening price of the order and the 

level of partial closure of positions. Positive values denote a partial closure on a gain (Take Profit), while 
negative values denote a partial closure on a loss (Stop Loss). 
 

In the “Percent” column, we specify the percentage of the current (not original) position size that will be 
closed at a selected price level. 
 

A value of the “SL/TP” column is automatically updated depending on whether the value in the “Points” 
column is positive or negative. 
 

Hidden Stop Loss / Take Profit 
 

Using the “Partial Close” option, we can also define hidden Stop Losses and hidden Take Profits. All we 
need to do is to set the value in the “Percent” column to 100 at a given level. 
 

 

 

 

 

 

 

 

 

 

 

 



 

15 
 

 

Keyboard shortcuts 
 

On the “Shortcuts” tab, we can assign our 
own keyboard shortcuts to certain actions. 
 

A keyboard shortcut key is active if it is 
selected (on the left side) and the “Use 
Shortcuts” field is checked. 
 

For a given shortcut, first we choose a 
function key from the list and then we type a 
keyboard character (a letter or a number, it 
can also be e.g. F4). 
 

Assign the same shortcut to actions “Open 
Buy” and “Open Sell” to define a shortcut 
which opens two opposite orders at the same 
time. 
 

 

 

 

 

 

Opening/Closing of orders at a given time 
 

The “Time” tab enables to define when a long 
order or a short order will be opened, and 
when all orders will be closed. 
 

Orders are opened with the parameters that 
are currently entered in the FTM main 
window, in the currently selected tab. 
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Information 
 

The “Info” tab enables to define the type of 
information which will be displayed on the 
screen. 
 

If you want to trade with a single click without 
the necessity to confirm the action, select 
“One Click” option. 
 
Select the “Execution Info” option to receive 

information that an order has been opened/closed. 
 

If you select the “Error Info” option, you will receive information about errors during opening/closing 
orders. 
 

 

Presets 
 

FTM offers the opportunity to save our own settings. It is possible to save the whole configuration of the 
FTM main window, order table, as well as all the parameters in the settings. 
 
The Presets window can be opened by clicking Tools->Presets. 

To save a new preset, enter its name in the text box, 

and then click the “Save” button. 

The new preset will appear in the drop-down list and 
will be available even after closing the program. 
 

To load a previously selected preset, select it from the 
drop-down list and click the Load “button”. 
 

To delete a previously saved preset, select it from the 
drop-down list and click the “Delete” button. 
 

After restarting FTM, it is loaded with the last preset. 
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Ability to run the FTM on the historical tester 
FTM is an excellent tool to simulate trading on historical data. 
 
To test your skills and feel of the market, run FTM on the historical tester built in the MT4 platform. 
 

Before starting FTM on the built in historical tester, allow for importing DLL files in the MetaTrader 4 
settings. In order to do this, select Tools -> Options (Ctrl + O) in MetaTrader 4 and then open the “Expert 
Advisors” tab. Check, if the “Allow automated trading” and “Allow DLL imports” options are active. 
 

 
 

After starting FTM on the historical tester, an additional panel 
which enables to adjust speed appears in the main window. 
 

 

 

 

The most convenient way is to choose the “Visual mode” 
option in the MT4 built in historical tester and set the maximum speed of the historical tester and then 
adjust the speed in the FTM tester speed panel. 

 


